SocialEngine Installation

Step 1: Check Requirements

Great! Next, let's make sure your server has everything it needs to support SocialEngine. If any of the requirements below are marked with red, you will need to address them before continuing. If items are marked with yellow, we recommend that you address them before installing, but you can continue if you wish.


  • PHP 7
    OK
  • MySQL
    OK
  • mod_rewrite
    Unable to check.
  • PHP Safe Mode OFF
    OK
  • PHP Register Globals OFF
    OK
  • GD
    OK
  • Imagick
    For optimal results with GIF images, we recommend adding the Imagick extension.
  • Iconv
    OK
  • Multi-byte String
    OK
  • PCRE
    OK
  • Curl
    OK
  • Session
    OK
  • DOM
    OK
  • Exif
    OK
  • Public Directory Permissions
    OK
  • Temp Directory Permissions
    OK
  • Settings Directory Permissions
    OK
  • Packages Directory Permissions
    OK
  • Install Permissions
    OK
  • Language Directory Permissions
    OK
  • Theme Directory Permissions
    OK
  • OpenSSL
    OK